Problems with checking out
Incident Report for SmugMug
Resolved
The issue with the upstream provider has been resolved. The shopping cart is now functioning correctly again.
Posted about 2 months ago. Jun 20, 2017 - 14:22 PDT
Identified
We're experiencing problems with checking out via the shopping cart due to an upstream provider issue.
Posted about 2 months ago. Jun 20, 2017 - 12:07 PDT
This incident affected: Web.