Read-only: Unexpected maintenance
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted May 16, 2015 - 05:58 PDT
Identified
We’re moving SmugMug into temporary read-only mode so we can safely troubleshoot an issue. Sorry for the hassle! We’ll be back ASAP.
Posted May 16, 2015 - 05:13 PDT
This incident affected: Web, Photos/Videos, Search, Support & Help Pages, and Uploads.