Watermarks processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 05, 2017 - 12:16 PST
Investigating
Watermarks are processing slowly. Our team is working on working through the backlog.
Posted 4 months ago. Jan 05, 2017 - 10:42 PST
This incident affected: Uploads.