Pages loading slowly
Incident Report for SmugMug
Resolved
This incident was caused by our CDN provider's errors, affecting some regions of the US. Their issue was resolved at 17:15 Pacific.
Posted 6 months ago. Dec 02, 2016 - 18:33 PST
Investigating
Pages are loading more slowly than usual. Our engineers are on the case.
Posted 6 months ago. Dec 02, 2016 - 15:53 PST
This incident affected: Web.