Images loading slowly
Incident Report for SmugMug
Resolved
Image performance is back to normal.
Posted May 10, 2014 - 19:04 PDT
Identified
Custom-sized images are loading more slowly than usual. Our engineers are on the case.
Posted May 10, 2014 - 18:54 PDT
This incident affected: Web and Photos/Videos.