Stats are processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Mar 10, 2016 - 23:22 PST
Identified
Stats are arriving slowly due to our content delivery network's problems with log delivery.
Posted Mar 10, 2016 - 17:04 PST