Pages loading slowly
Incident Report for SmugMug
Resolved
We've identified and fixed the source of this problem. Thank you for your patience.
Posted Nov 21, 2014 - 20:09 PST
Identified
Pages are loading more slowly than usual. Our engineers are on the case.
Posted Nov 21, 2014 - 19:06 PST
This incident affected: Web, Photos/Videos, and Uploads.