Read-only: Unexpected maintenance
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 12, 2018 - 14:09 PDT
Identified
We’re moving SmugMug into temporary read-only mode so we can safely troubleshoot an issue. Sorry for the hassle! We’ll be back ASAP.
Posted 3 months ago. Mar 12, 2018 - 13:48 PDT
This incident affected: Web, Photos/Videos, Search, and Uploads.