Stats are processing slowly
Incident Report for SmugMug
Resolved
Photo/video stats are now caught up and processing normally.
Posted Oct 26, 2014 - 08:21 PDT
Identified
Stats are processing slowly. Our engineers have identified this issue but we do not yet have an estimate for when they will be caught up to current.
Posted Oct 25, 2014 - 08:51 PDT