Uploads processing slowly
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted 8 months ago. Aug 22, 2016 - 20:05 PDT
Identified
Uploads are processing slowly. We're working on handling a large influx of new uploads. We will update here when processing time has returned to normal.
Posted 8 months ago. Aug 22, 2016 - 16:24 PDT
This incident affected: Web and Uploads.