Read-only tonight: Scheduled maintenance
Incident Report for SmugMug
Resolved
Work completed. Happy New Year to all!
Posted Jan 01, 2014 - 21:18 PST
Monitoring
Tonight's maintenance work has started.
Posted Jan 01, 2014 - 21:02 PST
Identified
We’re planning to give SmugMug some TLC from 21:00-21:30 Pacific. Thanks for your understanding!
Posted Jan 01, 2014 - 16:38 PST