Mail Outage
Incident Report for SmugMug
Resolved
Looks like our provider is back up and running.
Posted Jan 24, 2014 - 11:58 PST
Investigating
Our outgoing mail service is currently offline. We can not respond to help requests via email right now. We apologize for this delay in getting back to you, and will respond as soon as we can. Thank you for your patience.
Posted Jan 24, 2014 - 11:14 PST
This incident affected: Support & Help Pages.