Upload problems
Incident Report for SmugMug
Resolved
This incident has been resolved.
Posted Jun 04, 2015 - 19:51 PDT
Investigating
We’re seeing some issues with photo and video uploads. We’ll take a closer look and will update you when we have a fix.
Posted Jun 04, 2015 - 19:44 PDT
This incident affected: Uploads.